Chorn Sokun's Weblog

Conquer inner fear, push it to the limit!

Debugging failed because integrated Windows authentication is not enabled

leave a comment »

On of the annoying error message while trying to debug my ASP.NET application.

The fact, I just did a clean install my machine (winxp) and manually create virtual directory from IIS and epected it just work, but no I need to perform a few additional step to make thing work.

Enable Integrated Windows Authentication on the local IIS

  1. Open IIS Manager (Internbet Information Services)
  2. Right-click the web site (in case you run it locally you only have Default web site) and pick Properties
  3. Choose “Directory Security” tab and click Edit on “Anonymous access and authentication control
  4. In the opening window, uncheck “Allow Anonymous access” and check “Integrated Windows Authentication” (allowing anonymous can make that you don’t have enough permissions to debug)

Hope I don’t forget it again ;)

Advertisements

Written by Chorn Sokun

January 9, 2007 at 10:14 am

Posted in Tips & Tricks

Tagged with ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: